Networkümüzü Bufferbloat’dan Nasıl Kurtarırız?

Networkümüzün en sıkıntılı durumlarından biri olan Bufferbloat’ı 2017 yılında elimden geldiğince anlatmıştım, konu ile ilgili önerilen çözüm yöntemlerinide belirtmiştim. Bugün işte bu yöntemlerden birini uygulayacağız. Hatrı sayılır bir şekilde iyileşme sağlayacağımızdan emin olabilirsiniz.

Yapılandırmamızı yapmadan önceki ilk testimizde networkümüzün durumunu şöyle göstereyim ki farkı görelim.

file

Benim elimdeki router bildiğiniz gibi MikroTik RB750Gr3 bunun üzerinde donanımsal olarak kuyruklama var gibi gözükebilir. Yani aslında kuyruk aktif bile değil. Mikrotikte birden fazla kuyruk yönetim şekli bulunuyor, download ve/veya upload için ayrı ayrı tip belirleyebilirsiniz.

Ayarlayabileceğiniz kuyruk tipleri şunlar

  • bfifo, mq pfifo, pfifo
  • cake
  • codel
  • fq codel
  • none
  • pcq
  • ref
  • sfq

Yaptığım testler ile gördüm ki sfq ve codel kafa kafaya gidiyor ve daha iyi bir sonuç veriyor. Bende yapılandırmamı buna göre yapacağım. Testlerinizde diğer algoritmaları iyi sonuç verirse kendinizde ona göre değişiklik yapabilirsiniz.

UYARI: Ön tanımlı açık gelen Fasttrack kapatmayı unutmayınız.

/queue type
add kind=sfq name=sfq-default-queue sfq-perturb=10

/queue simple
add max-limit=18M/98M name=main-queue queue=sfq-default-queue/sfq-default-queue target=192.168.88.0/24

İşlemimiz başarılı bir şekilde tamamlandı artık, yapmamız gereken DSLReport sitesi aracılığı ile testimizi yapmak.

Yukarıda ayarları yaptıktan sonraki networkümüzün durumu

file

Cihazımda Bunu Nasıl Uygularım?

Ev kullanıcısı için pek fazla seçenek yok kaliteli network ekipmanı gerekiyor en başta cihazın cipseti Broadcomm veya Qualcomm ise cihazınız OpenWRT tabanlı yazılımları destekliyor demektir listeye buradan ulaşabilirsiniz.

Bu tarz cihazlarda kullanacağınız kuyruk yönetim algoritması SQM(Smart Queue Management) olarak geçmektedir.

Asus cihazlar için Asuswrt-Merlin kullanacaksınız. Tp-Link kullananlar OpenWRT veya dd-wrt kurabilirler.

Elinizde başka cihaz bulunuyorsa https://dd-wrt.com/support/router-database/ web sitesinden sorgulayabilirsiniz.

Share this:

Leave a Comment

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.