Network

MikroTik’de DNS over HTTPS (DoH) Nasıl Aktif Edilir?

16 Haziran 2020

MikroTik’de DNS over HTTPS (DoH) Nasıl Aktif Edilir?

Bu özellik RouterOS version v6.47 sürümü ile birlikte geliyor, bu güncellemeyi resmi sitesinden edinip cihazınızı yükselttikten sonra aşağıdaki işlemleri yapın.

CloudFlare Tarafındaki DoH için yapılacak işlemler sırasıyla aşağıdaki gibidir. Root CA mutlaka mikrotik içerisine eklenmeli

/tool fetch url="https://cacerts.digicert.com/DigiCertGlobalRootCA.crt.pem"
/certificate import file-name=DigiCertGlobalRootCA.crt.pem

Ardından sunucu tanımı yapılmalı

/ip dns set use-doh-server=https://cloudflare-dns.com/dns-query verify-doh-cert=yes

DoH çalışabilmesi için router üzerinde dns tanımlı olması gerekmektedir. Bu yüzden statik olarak herhangi bir dns tanımlanmalı

/ip dns set servers=1.1.1.1

Yapılan bu ayarlar Winbox uygulamasında şu şekilde gözükür.

mikrotik winbox gösterim, mikrotik winbox dns settings, mikrotik winbox dns ayarları

MikroTik Üzerinde DNS Günlükleme

Çalışıp çalışmadığını görmek isteyenler öncelikle DNS loglamasını açmalı, aşağıdaki gibi yapılır.

mikrotik dns logging, mikrotik dns günlükleme, mikrotik log

Ardından torch ile rahatlıkla dns logları izlenebilir.

mikrotik torch kullanımı,torch ile network izleme, mikrotik network monitoring, mikrotik network status

Sistem Uzmanı, Linux Hacısı, El-Kernel
Yorum yap

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir